NerdNOS.net Logo

Running an IBM ServeRaid PPC Card on Windows XP Professional

Hey all,

Just thought I'd share a little bit of inf hacking with you, so anyone with a PPC IBM ServerRaid card, or any other card that has Windows 2000 Server or Windows Server 2003 Drivers, but no XP Drivers.

I bought this card for $4.95 off E-bay, and I wanted to use it in my desktop. Its not for big speed or anything, just to play with.

Original INF:

;
; oemsetup.inf -- INF setup file for ipsraidn ServeRAID Adapters
; for Windows 2000 and Windows XP Servers.
; Copyright (c) 1998-2004, IBM
; Copyright 2004 Adaptec, Inc. All rights reserved.

[Version]
Signature = "$Windows NT$"
Class = SCSIAdapter
ClassGUID = {4D36E97B-E325-11CE-BFC1-08002BE10318}
Provider = %IBM%
CatalogFile = ipsraid2.cat
DriverVer=07/12/2004, 7.10.18

[SourceDisksNames]
1 = %INSTALL_MEDIA_DESCRIPTION%, WINDOWSWIN2K_XPSCSIPPCDRVRIPSRAIDN.SYS,

[SourceDisksFiles]
ipsraidn.sys = 1
nfrdci04.dll = 1

[DestinationDirs]
IPSRAIDN_CopyFiles = 12 ; WINNTSYSTEM32DRIVERS
NFRDCI_CopyFiles = 11 ; WINNTSYSTEM32

[Manufacturer]
%IBM%=IBM,NTx86.5.1.0x1

; models section

[IBM.NTx86.5.1.0x1] ; Section for XP Professional

[IBM]
%SERVERAID4H_DESCRIPTION% = IPSRAIDN_Install, PCIVEN_1014&DEV_002E&SUBSYS_022E1014&REV_10
%SERVERAID3_DESCRIPTION% = IPSRAIDN_Install, PCIVEN_1014&DEV_002E&SUBSYS_002E1014&REV_0D
%SERVERAID2_DESCRIPTION% = IPSRAIDN_Install, PCIVEN_1014&DEV_002E&SUBSYS_00000000&REV_04
%SERVERAIDNAV_DESCRIPTION% = IPSRAIDN_Install, PCIVEN_1014&DEV_002E&SUBSYS_00000000&REV_03
%SERVERAID1_DESCRIPTION% = IPSRAIDN_Install, PCIVEN_1014&DEV_002E&SUBSYS_00000000&REV_02

[ControlFlags]
** SNIP **

As you can see, IBM has a special section in their INF for XP Professional, which is empty. This makes all the drivers not work for it, basically says there is no information about your hardware. I did a simple change to that section.

[IBM.NTx86.5.1.0x1] ; Section for XP Professional
%SERVERAID4H_DESCRIPTION% = IPSRAIDN_Install, PCIVEN_1014&DEV_002E&SUBSYS_022E1014&REV_10
%SERVERAID3_DESCRIPTION% = IPSRAIDN_Install, PCIVEN_1014&DEV_002E&SUBSYS_002E1014&REV_0D
%SERVERAID2_DESCRIPTION% = IPSRAIDN_Install, PCIVEN_1014&DEV_002E&SUBSYS_00000000&REV_04
%SERVERAIDNAV_DESCRIPTION% = IPSRAIDN_Install, PCIVEN_1014&DEV_002E&SUBSYS_00000000&REV_03
%SERVERAID1_DESCRIPTION% = IPSRAIDN_Install, PCIVEN_1014&DEV_002E&SUBSYS_00000000&REV_02

[IBM]
** SNIP**

Now it works perfectly. Thanks IBM for ruining 30 minutes of my life while I tried to get your ****ing driver working. Screwing around looking for another driver before I got mad and just hacked the one that came with the Resource CD.

So now you know, if you have some **** that just doesn't wanna work, **** with the INF file, the worst you'll do is need to reinstall Windows or maybe lose all your data, but you have a backup anyways. Right?

Written by Dan on 2007-11-12 18:28:50

Login to NerdNOS
Username:  
Password:  
Register with NerdNOS